Variable Names Plan¶
This plan is provisional. It is not agreed upon. It is written with the intention of capturing the desires and concerns of the LLVM community, and forming them into a plan that can be agreed upon. The original author is somewhat naïve in the ways of LLVM so there will inevitably be some details that are flawed. You can help - you can edit this page (preferably with a Phabricator review for larger changes) or reply to the Request For Comments thread.
Improve the readability of LLVM code.
The current variable naming rule states:
Variable names should be nouns (as they represent state). The name should be camel case, and start with an upper case letter (e.g. Leader or Boats).
This rule is the same as that for type names. This is a problem because the
type name cannot be reused for a variable name [*]. LLVM developers tend to
work around this by either prepending
The to the type name:
… or more commonly use an acronym, despite the coding standard stating “Avoid abbreviations unless they are well known”:
The proliferation of acronyms leads to hard-to-read code such as this:
InnerLoopVectorizer LB(L, PSE, LI, DT, TLI, TTI, AC, ORE, VF.Width, IC, &LVL, &CM);
Many other coding guidelines [LLDB] [Google] [WebKit] [Qt] [Rust] [Swift] [Python] require that variable names begin with a lower case letter in contrast to class names which begin with a capital letter. This convention means that the most readable variable name also requires the least thought:
There is some agreement that the current rule is broken [LattnerAgree] [ArsenaultAgree] [RobinsonAgree] and that acronyms are an obstacle to reading new code [MalyutinDistinguish] [CarruthAcronym] [PicusAcronym]. There are some opposing views [ParzyszekAcronym2] [RicciAcronyms].
This work-in-progress proposal is to change the coding standard for variable names to require that they start with a lower case letter.
There are two main options for variable names that begin with a lower case
lower_case. (These are also known by other names
but here we use the terminology from clang-tidy).
camelBack was expressed by [DenisovCamelBack]
camelBack was expressed by [CarruthCamelBack]
lower_case was expressed by [CarruthLower]
lower_case was expressed by [LattnerLower].
An additional requested change is to distinguish between different kinds of variables [RobinsonDistinguish] [RobinsonDistinguish2] [JonesDistinguish] [IvanovicDistinguish] [CarruthDistinguish] [MalyutinDistinguish].
A possibility is for member variables to be prefixed with
m_ and for global
variables to be prefixed with
g_ to distinguish them from local variables.
This is consistent with [LLDB]. The
m_ prefix is consistent with [WebKit].
While switching coding standard will make it easier to use non-acronym names for new code, it doesn’t improve the existing large body of code that uses acronyms extensively to the detriment of its readability. Further, it is natural and generally encouraged that new code be written in the style of the surrounding code. Therefore it is likely that much newly written code will also use acronyms despite what the coding standard says, much as it is today.
As well as changing the case of variable names, they could also be expanded to
their non-acronym form e.g.
Triple T →
The consensus within the community seems to be that at least some acronyms are
valuable [ParzyszekAcronym] [LattnerAcronym]. The most commonly cited acronym
TLI however that is used to refer to both
The following is a list of acronyms considered sufficiently useful that the benefit of using them outweighs the cost of learning them. Acronyms that are either not on the list or are used to refer to a different type should be expanded.
In some cases renaming acronyms to the full type name will result in overly
verbose code. Unlike most classes, a variable’s scope is limited and therefore
some of its purpose can implied from that scope, meaning that fewer words are
necessary to give it a clear name. For example, in an optimization pass the reader
can assume that a variable’s purpose relates to optimization and therefore an
OptimizationRemarkEmitter variable could be given the name
The following is a list of longer class names and the associated shorter variable name.
There are three main options for transitioning:
Keep the current coding standard
Proponents of keeping the current coding standard (i.e. not transitioning at
all) question whether the cost of transition outweighs the benefit
[EmersonConcern] [ReamesConcern] [BradburyConcern].
The costs are that
git blame will become less usable; and that merging the
changes will be costly for downstream maintainers. See Big bang for potential
The coding standard could allow both
camelBack styles for
variable names [LattnerTransition].
A code review to implement this is at https://reviews.llvm.org/D57896.
Very easy to implement initially.
With this approach, variables will be renamed by an automated script in a series of large commits.
It goes against a policy of avoiding large-scale reformatting of existing code [GreeneDistinguish].
It has been suggested that LLD would be a good starter project for the renaming [Ueyama].
git blame (or
git annotate) permits quickly identifying the commit that
changed a given line in a file. After renaming variables, many lines will show
as being changed by that one commit, requiring a further invocation of
blame to identify prior, more interesting commits [GreeneGitBlame]
can ignore or “look through” a given set of commits.
.git-blame-ignore-revs file identifying the variable renaming commits
could be added to the LLVM git repository root directory.
It is being investigated
whether similar functionality could be added to
git blame itself.
There are many forks of LLVM with downstream changes. Merging a large-scale renaming change could be difficult for the fork maintainers.
Mitigation: A large-scale renaming would be automated. A fork maintainer can merge from the commit immediately before the renaming, then apply the renaming script to their own branch. They can then merge again from the renaming commit, resolving all conflicts by choosing their own version. This could be tested on the [SVE] fork.
This is a provisional plan for the Big bang approach. It has not been agreed.
git blame. The extent to which it can be made to “look through” commits may impact how big a change can be made.
Write a script to expand acronyms.
Experiment and perform dry runs of the various refactoring options. Results can be published in forks of the LLVM Git repository.
Consider the evidence and agree on the new policy.
Agree & announce a date for the renaming of the starter project (LLD).
Update the policy page. This will explain the old and new rules and which projects each applies to.
Refactor the starter project in two commits:
Add or change the project’s .clang-tidy to reflect the agreed rules. (This is in a separate commit to enable the merging process described in Minimising cost of downstream merges). Also update the project list on the policy page.
clang-tidyto the project’s files, with only the
clang-tidywill also reformat the affected lines according to the rules in
.clang-format. It is anticipated that this will be a good dog-fooding opportunity for clang-tidy, and bugs should be fixed in the process, likely including:
Gather feedback and refine the process as appropriate.
Apply the process to the following projects, with a suitable delay between each (at least 4 weeks after the first change, at least 2 weeks subsequently) to allow gathering further feedback. This list should exclude projects that must adhere to an externally defined standard e.g. libcxx. The list is roughly in chronological order of renaming. Some items may not make sense to rename individually - it is expected that this list will change following experimentation:
Remainder of llvm
Remove the old variable name rule from the policy page.
Repeat many of the steps in the sequence, using a script to expand acronyms.
LLDB Coding Conventions https://llvm.org/svn/llvm-project/lldb/branches/release_39/www/lldb-coding-conventions.html
Google C++ Style Guide https://google.github.io/styleguide/cppguide.html#Variable_Names
Qt Coding Style https://wiki.qt.io/Qt_Coding_Style#Declaring_variables
Rust naming conventions https://doc.rust-lang.org/1.0.0/style/style/naming/README.html
Swift API Design Guidelines https://swift.org/documentation/api-design-guidelines/#general-conventions
Style Guide for Python Code https://www.python.org/dev/peps/pep-0008/#function-and-variable-names
Mozilla Coding style: Prefixes https://firefox-source-docs.mozilla.org/tools/lint/coding-style/coding_style_cpp.html#prefixes
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130313.html
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130214.html
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130310.html
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130309.html
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130312.html
Chandler Carruth, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130430.html
James Henderson, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130465.html
Nemanja Ivanovic, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130249.html
Danila Malyutin, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130320.html
Krzysztof Parzyszek, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130306.html
Krzysztof Parzyszek, http://lists.llvm.org/pipermail/llvm-dev/2019-February/130323.html
Krzysztof Parzyszek, http://lists.llvm.org/pipermail/llvm-dev/2019-February/129941.html